View Full Version : External drive - access denied

16-Nov-09, 13:22
Hi everybody, I am new to these forums, and have to tell you before I start that am not technically minded at all, so please be patient with me.

I have Maxter external drive and until recently have had no problems - but now I am unable to access it. When I open my computer the F: drive is showing as one of those window icons- but if I try to open or explore it says Access denied.

I did look into the properties and everthing looked okay to me (thats not saying much I know) - also when looking at permissions for this drive - all say allowed for me and for system.

I have a lot of files on this ext drive and hope that I will not lose them.
I went into the help and support files and tried everything I could find there. No luck. I did try something - can't remember what now (its my age you know!!) but I know it said that windows could not access this drive either.

Also when I turned my comp on it said that it needed to check the f: drive for inconsistencies. let it do this. but no change.

Checked in the hardware list and it says this device is working properley. have run all anti-virus scans etc and disc checks on this drive - all come back saying its ok
Totally confused and ready to chuck it out of the window now. My comp is running windows vista - if that makes any difference.

Please help this old lady out.


16-Nov-09, 13:33
I have the same problem with 2 of my maxtors. The only way i could get it to work is to pull out the power pin at the back of the hard drive next to the usb cable and put it back in again.
I know that your not supposed to do it that way but it works for me.

16-Nov-09, 13:48

Nope, have just tried pulling the plug as you suggested but - still access denied.

any other ideas???

16-Nov-09, 14:40
By any chance have you changed or upgraded your operating system or computer since the drive worked?

Also in the properties of the drive do you see anything saying FAT32 or NTFS? if so which one?

Regardless, try this on the HDs security tab http://support.microsoft.com/kb/308421

16-Nov-09, 15:00
Hi Rec Query, As far as I can remember have done nothing to change my pc, no upgrades etc. only ordinary windows, java and adobe updates.

On properties list it states NTFS.

Tried that link, have looked and permission are all on allow.


16-Nov-09, 17:23
Even if its set on allow all, due to the nature of permissions could you just humour me and do the take ownership thing.

To save me having to paraphrase there is a guide here (http://www.le.ac.uk/cc/dsss/docs/acls2.shtml)with screenshots, the procedure should be similar for both XP and Vista.

If that doesn't work try changing the USB port used.

If that doesn't work bring up a command prompt:

Either go Start>All Programs>Accessories>Command Prompt or Start>Run>cmd>OK or Start>Search>cmd depending on the OS)

then enter the command

chkdsk /f f:

You might be prompted to unmount just select yes and wait.

If that doesn't work post back here.

BTW Do you know if its Vista or XP your running?

16-Nov-09, 18:34
This sounds similar to a problem I have experienced previously (posted here (http://forum.caithness.org/showthread.php?t=20093)).

Firstly I'd try connecting it to another PC - can you access the files? If so then, like above, it sounds like a problem with drive permissions - this may well require a backup, wipe & reinstall of the main PC in order for it to recognise the drive again.

At least with an external drive it should be possible to dismantle it and install the bare drive in a PC as a 2nd unit, thereby allowing access to its contents.

Let us know how you get on.