View Full Version : Linux help please

Loch not Lock
04-Nov-09, 17:40
I have just bought a new computer which is an Acer Extensa 420 and runs on Linux rather than Microsoft but I have spent all day trying to get it to connect to the Internet without success. I have gone back to my old computer - that's how I am able to make this post. Is there some computer whizz-kid out there who can advise me. It would be greatly appreciated. :confused

04-Nov-09, 18:01
Can you give some more details?
How are you trying to connect - wireless, wired etc? Type of router, type of encryption? What problems you are receiving?
I'm currently on my acer web book which is also running linux and it was the most simple process to connect it to my current wireless network. Just went to network centre, added my wireless connection and the security details and hey ho. Used it at several friends houses as well. Had some faffing with windows in my time but no probs here.

Basically more info required!

Loch not Lock
04-Nov-09, 18:28
Thank you Serenity. I have tried both by wired and by a new Linsky router which is compatible with Linux. As I am very ignorant when it comes to technical ins and outs of computing I am sure I am just failing to press the correct buttons. I get on to the Linux homepage but get stuck when trying to access the Internet. I am willing to pay for practical help if you are local to Thurso.

04-Nov-09, 18:38
I've always had excellent help on the Technical Support forum. If anyone can solve your problem the guys who browse there can. Good luck.;)

Loch not Lock
04-Nov-09, 19:33
I've always had excellent help on the Technical Support forum. If anyone can solve your problem the guys who browse there can. Good luck.;)
Many thanks, Venture. My fingers are crossed.:)

04-Nov-09, 21:30
If you plug it in via an ethernet cable, 90% of the time, it should just work. Anyway a few questions:

What version of Linux is it running? Do you see anything when you're waiting for it to boot up? Ubuntu, Debian, Fedora or Xandros ring any bells?
Are you seeing what looks like a traditional desktop or something different?
What does the Linux homepage look like? What happens when you put an address in?
Where did you buy it?
How does your Windows PC connect to the Internet? If via a cable have you tried plugging the Linux PC into the same router? (Apologies I wasn't sure if the Linksys router you mentioned was the one beening used for the Internet)

Okay all that being said, lets try and work out whats wrong without any of that, If you can make a note of stuff below and post it here.

First plug it in via cable (if we can get cable working we'll move to wireless later)

Don't worry if you can't find any of this but look around the desktop/interface for something with console, term or terminal in the name it might be under accessories, utilities or system if you find it, click it. If you can't find it try holding Ctrl and Alt then pressing T to see if that brings anything up.

If successful you'll see something that looks like this:


Though there are several variations. If you get to this stage you might want to maximise the window. Anyway assuming we get to this stage, enter the following command, tapping enter/return where indicated:

ping google.co.uk [enter]

After a few lines are printed to screen hold down Ctrl and tap C, the output should look similar to this:

PING google.co.uk ( 56(84) bytes of data.
64 bytes from gv-in-f104.1e100.net ( icmp_seq=1 ttl=54 time=95.9 ms
64 bytes from gv-in-f104.1e100.net ( icmp_seq=2 ttl=54 time=94.3 ms
64 bytes from gv-in-f104.1e100.net ( icmp_seq=3 ttl=54 time=93.1 ms
^CNow enter the command:

ifconfig [enter]

this will output alot to the screen, I'm only looking for a few lines, anything similar to:

eth0 Link encap:Ethernet HWaddr AA:11:BB:22:CC:33
inet addr: Bcast: Mask: might be more than one of theses.

Now enter the command

netstat -nr [enter]

The output will look similar to this:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface MSS Window irtt U 1 0 0 eth0 0 0 0 UG 0 0 0 eth0 0 0 0If you get all of this. move to your Windows PC, and bring up a command prompt (Either go Start>All Programs>Accessories>Command Prompt or Start>Run>cmd>OK or Start>Search>cmd depending on the OS)

now enter the command:

ipconfig /all [enter]

and thats us for the time being.


I'm not sure of anyone who supports Linux locally, you could try calling around (ideally make sure they have a no fix no fee policy considering its a Linux problem)

Loch not Lock
05-Nov-09, 00:19
I have printed out your advice RecQuery and will work on it during the next few days. It is so kind of you to spend such a long time writing out these solutions.:)
I just hope I'm not too technically thick to sort it out.:confused
By the way I bought it online from Ebuyer who I have found to be most reliable in the past.
I am sure it is not the machine - it is me!

05-Nov-09, 01:24
Yeah, I wanted to check that the hardware would be supported.

Check this


Tell me if it looks like what you see? If so your Distro (version of Linux) is called Linpus and is based on another distro called called Fedora. Its not the best starting point but we'll see what we can do:

If its Linpus you can get a terminal by going:

1. Pressing "ALT + F2"
2. Enter "terminal"

see if its working if so try the command below if not

3. Enter "su -"
4. Enter your root password

The Root password would of been set when you turned it on or might be in the documentation somewhere.

In light of this new information (ostensibly if my assumption turns out to be true) the first thing to do after getting a terminal is to enter the following command

rm -rf ~/.gconf/system/networking [enter]

If you're having trouble getting ~ hold shift and tap #

and restart to see if its working, if not check Settings>Network Center for information and settings

Finally if theres still no progress go back to my first post.

Loch not Lock
05-Nov-09, 23:51
Sorry for not replying for your detailed help sooner, RecQuery but I have been very busy today and will be again tomorrow. On Sunday I should have time to link up the Linux computer and get to work on your suggestions. I do believe it is Limpus supported.
Many thanks again for your time and effort.:)