View Full Version : Vista SP1/2 Update Problem

16-Sep-09, 13:07
Having problems with my DELL PC lately (Yes, I know I should have bought a proper PC!) and noticed that many of my updates have been failing. Noteably SP1 (and hence can't get SP2). Despite a search on MS knowledge base I am still none the wiser - any suggestions from you budding techno heads?:confused

Mr P Cannop
16-Sep-09, 13:19
are you in thurso ??

16-Sep-09, 13:31
Yes, why do you ask?

Mr P Cannop
16-Sep-09, 13:35
i can come and try and help you if you want me too ??

16-Sep-09, 14:09
what anti virus you running

nortons is known to cause these issues.

if not
i'd try running chkdsk.

type cmd in the search box bottom left
then type chkdsk c: /r /f
say yes tothe question and then reboot

try vista sp1 then.


17-Sep-09, 09:08
Running AVG free - so not the best and am going to upgrade.

Tried installing Glaryutilities and going through all of the utilities in that (appeared to clean up a very messy registry amongst other things)

I then tried as you suggested with no success.

My main problem hasn't been the lack of SP1 or 2 ( i thought updating the OS might help though?) my main problem has been for the past couple of weeks my computer continually fails to start….. when switched on, it will either do nothing, run the bios and then do nothing, run the bios then look as though it is starting windows and then do nothing etc….. Perseverance (switching on and off a number of times!) usually results in the option to Launch startup repair which usually works although sometimes I just get the blue screen of death.

The following are examples of error messages:

(after selecting ‘Launch Startup Repair – almost immediately went to blue screen)

‘The cryptographic subsystem failed a mandatory algorithm self-test during bootstrap’

Technical Info: *** STOP: 0x00000123 (0x00000000,0x00000000,0x00000000)


(again after selecting ‘Launch Startup Repair but this time looked like it was starting windows but went to blue screen)


Technical Info: *** STOP: 0x000000D1 (0x00000000,0x00000002,0x83445AD8)

Getting really pee'd off and trying to avoid wiping the whole thing and starting again.


17-Sep-09, 14:41
you are on a hiding with that error

i would try resetting the bios to bios defaults.



you need to resolve this error before trying any upgrading.


17-Sep-09, 15:13
I'd recommend backing up the data (attach hard drive using an external USB interface and connecting to a 2nd PC), then wiping & reinstalling the system, & get the SP and updates on before putting anything back onto it.

17-Sep-09, 18:06
I'd recommend backing up the data (attach hard drive using an external USB interface and connecting to a 2nd PC), then wiping & reinstalling the system, & get the SP and updates on before putting anything back onto it.

yep my exact thoughts in the 1st place

but the op seems to want to avoid/ does not have disc.


17-Sep-09, 20:30
Thanks for the advice - got all the discs but was trying to avoid taking such drastic action!

complete wipe it is then.....

21-Sep-09, 22:18
DRIVER_IRQL_NOT_LESS_OR_EQUAL usualy indcates some kind of hardware fault. The fact that it sometimes takes a few attempts to start the PC, also makes me suspect a hardware fault.

Bobs sugestion is a good place to start, but suspect the problem might re-occur. If your still having problems feel free to PM me.

23-Sep-09, 12:57
Thanks for the suggestion.

However, I have now re-installed the OS and have finally got all of the available updates installed and everything appears to be working ok for now. Just got to get MS Office installed now.

23-Sep-09, 18:25
well pop on windows defender whilst you're there too


27-Sep-09, 08:23
i've got a similar problem but not nearly as serious as CW

windows downloads SP2 (vista), then when configuring updates comes to the end and says some files couldn't be changed and then goes and deletes all the updates - this happens every other day and getting fed up of it!

any suggestions?

27-Sep-09, 18:02
i'd be inclined to run glary or CCleaner or http://www.tuneup-software.co.uk/products/tuneup-utilities/

to see if it throws anything up

if all else fails, try running chkdsk
[this can be done
right click C: drive
check now tab.

let us know